KickBack Points Program - The Coalition transaction processing is currently offline
Incident Report for KickBack Rewards Systems
Resolved
This incident has been resolved.
Posted 12 days ago. Feb 12, 2018 - 12:23 MST
Investigating
Coalition transaction processing is currently offline due to a software upgrade. A large team of 5 are reviewing and will have the program online as quickly as possible.
Posted 12 days ago. Feb 12, 2018 - 11:24 MST