RewardsButler and Mobile API degraded performance - planned maintenance
Incident Report for KickBack Rewards Systems
Resolved
This incident has been resolved.
Posted 10 days ago. Nov 08, 2018 - 00:51 MST
Update
We are continuing to investigate this issue.
Posted 10 days ago. Nov 07, 2018 - 23:54 MST
Investigating
We are currently undergoing planned maintenance for RewardsButler and the Mobile API.
Posted 10 days ago. Nov 07, 2018 - 23:53 MST
This incident affected: RewardsButler.