Database Server Maintenance
Incident Report for KickBack Rewards Systems
Resolved
This incident has been resolved.
Posted 21 days ago. Jun 30, 2018 - 00:39 MDT
Investigating
Brief database server maintenance is occurring to the KickBack Points Coalition Loyalty Program
Posted 21 days ago. Jun 30, 2018 - 00:13 MDT
This incident affected: Coalition transaction processing.