Degraded performance - Promobuilder
Incident Report for KickBack Rewards Systems
Resolved
The network issue with our cloud vendor has been resolved. Promobuilder performance is now optimal.
Posted 4 months ago. Jun 08, 2017 - 13:56 MDT
Investigating
Promobuilder has degraded performance due to a networking issue with a cloud vendor. KRS is working to resolve the issue with our cloud vendor.
Posted 4 months ago. Jun 08, 2017 - 12:49 MDT